$re = '/(?:\d+\D+){3}\K\d+/';
$str = 'this11is22library33this44is55library';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);