import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s{1,}\\[Documentation]\\s*(.*)$|^\\s{1,}\\.{3}\\s*(.*)$";
final String string = "\n"
+ "${DISPLAY_LINE1} 0 #TARIFF Display\n"
+ "${DISPLAY_LINE2} 1 #EXTRAS Display\n"
+ "${DISPLAY_LINE3} 2 #FARE Display\n\n"
+ "@{TEST_SCREENS_WITH_TIMEOUT} ShowDesc ShowOsAndCountryCode ShowSW ShowSerial\n"
+ "... Checksum_PPSU Checksum_BPSU Checksum_LPSU Checksum_GPSU Checksum_AEPS Checksum_FEPS Checksum_GPAR\n"
+ "... Datetime_Clock Datetime_DDMM Datetime_Year\n"
+ "... ShowHWRevBaseboard ShowHWRevSOM Digio LVTL_Info\n"
+ "... TestMeasure_WDZ TestMeasure_SEC TestMeasure_MET TestMeasure_SPD\n\n"
+ "@{TEST_SCREENS_WITHOUT_TIMEOUT} DisplayTest DisplaySettings Temperature\n\n"
+ "@{CHECKSUM_SCREENS} Checksum_PPSU Checksum_BPSU Checksum_LPSU\n\n"
+ "*** Keywords ***\n"
+ "Program Version contain\n"
+ " [Documentation] Read out program version and compare it with ${PROGARMM_VERSION}\n"
+ " ... Comparison is done with \"Should Contain\" which is equal to Pythons \"in\" operator,\n"
+ " ... it checks if ${PROGARMM_VERSION} is a substring of display content.\n"
+ " ... Examples: Display content is \"P.ITM30\"\n"
+ " ... Should Contain P.ITM30 ITM30 => PASS\n"
+ " ... Should Contain P.ITM30 ITM => PASS\n"
+ " ... Should Contain P.ITM30 I => PASS\n"
+ " ... Should Contain P.ITM30 ITM40 => FAIL\n\n"
+ " [Arguments] ${PROGARMM_VERSION}\n\n"
+ " Fail if not on measure mode screen ShowOsAndCountryCode\n"
+ " @{disp} = Read display in measure mode\n"
+ " Should Contain @{disp}[${DISPLAY_LINE3}] ${PROGARMM_VERSION} Program version not found: ${PROGARMM_VERSION}\n\n\n"
+ "Tarif EPS is\n"
+ " [Documentation] Read out tarif EPS and compare it with ${TARIF_EPS}\n"
+ " ... Comparison is done with \"Should be equal\"\n"
+ " [Arguments] ${TARIF_EPS}\n\n"
+ " Fail if not on measure mode screen Checksum_AEPS\n"
+ " @{disp} = Read display in measure mode\n"
+ " ${disp_traf_eps} = Catenate SEPARATOR= @{disp}[${DISPLAY_LINE1}] @{disp}[${DISPLAY_LINE3}]\n"
+ " ${disp_traf_eps} = Replace String ${disp_traf_eps} . ${EMPTY}\n\n"
+ " Should be equal ${disp_traf_eps} ${TARIF_EPS} Tarif EPS is not equal\n\n\n"
+ "Release Date contain\n"
+ " [Documentation] Read out program version and compare it with ${RELEASE_DATE}\n"
+ " ... Comparison is done with \"Should Contain\" which is equal to Pythons \"in\" operator.\n"
+ " ... For more information about the in-operator read Program Version contain - Keyword\n\n"
+ " [Arguments] ${RELEASE_DATE}\n\n"
+ " Fail if not on measure mode screen ShowSW\n"
+ " @{disp} = Read display in measure mode\n"
+ " Should Contain @{disp}[${DISPLAY_LINE3}] ${RELEASE_DATE} Release date not found: ${PROGRAM_VERSION}\n\n\n"
+ "Checksum is not blinking\n"
+ " [Documentation] Check if checksums displayed in MEASURE MODE does blinking\n\n"
+ " [Arguments] ${CHECKSUM_SCREEN}\n\n"
+ " Fail if not on measure mode screen ${CHECKSUM_SCREEN}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}