$re = '/^[A-Za-z]{4}[a-zA-Z0-9]{7}$/';
$str = 'BARB0LDALUC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);