$re = '/(?<=^..)a{3}/m';
$str = 'xxaaahjhjhj
xaaahjhjhj
aaahjhjhj
aaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);