#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!V2).)*(- Dev|- Test)\s*$"
Local $sString = "AppMessages - Dev" & @CRLF & _
"AppMessages - Master" & @CRLF & _
"AppMessages2 - Dev" & @CRLF & _
"AppMessages2 - Master" & @CRLF & _
"AWS - Octopus Release" & @CRLF & _
"BellHop - Dev" & @CRLF & _
"BellHop - Master" & @CRLF & _
"Bellhop Model - Dev" & @CRLF & _
"Bellhop Model - Master" & @CRLF & _
"Bellhop Model V2 - Dev" & @CRLF & _
"Bellhop Model V2 - Master" & @CRLF & _
"BellHop Services - Dev" & @CRLF & _
"BellHop Services - Master" & @CRLF & _
"BSG Log4j Extras - Dev" & @CRLF & _
"BSG Log4j Extras - Master" & @CRLF & _
"BSG Log4j Extras V2- Dev" & @CRLF & _
"BSG Log4j Extras V2- Master" & @CRLF & _
"BSG-BOM - Dev" & @CRLF & _
"BSG-BOM - Master" & @CRLF & _
"BSG-BOM2 - Dev" & @CRLF & _
"BSG-BOM2 - Master" & @CRLF & _
"Core Model - Dev" & @CRLF & _
"Core Model - Master" & @CRLF & _
"Core Model V2 - Master" & @CRLF & _
"Core Model V2 - Dev" & @CRLF & _
"Core Services - Dev" & @CRLF & _
"Core Services - Master" & @CRLF & _
"Core Services V2 - Dev" & @CRLF & _
"Core Services V2 - Master" & @CRLF & _
"DealerLocator - Dev" & @CRLF & _
"EMS Services - Dev" & @CRLF & _
"EMS Services - Master" & @CRLF & _
"EMS Services V2 - Dev" & @CRLF & _
"EMS Services V2 - Master" & @CRLF & _
"Entitlements Services - Dev" & @CRLF & _
"Entitlements Services - Master" & @CRLF & _
"Entitlements SOAP API - Dev" & @CRLF & _
"Laipac Service - Master" & @CRLF & _
"Laipac Services - Dev" & @CRLF & _
"Laipac Services V2 - Dev" & @CRLF & _
"Laipac Services V2 - Master" & @CRLF & _
"LDK Services - Dev" & @CRLF & _
"LDK Services - Master" & @CRLF & _
"LDK Services V2 - Dev" & @CRLF & _
"LDK Services V2 - Master" & @CRLF & _
"LicenseAdmin - Dev" & @CRLF & _
"LicenseAdmin - Master" & @CRLF & _
"LiteFlexNetIntegration - Dev" & @CRLF & _
"LiteFlexNetIntegration - Master" & @CRLF & _
"LiteIntegration - Dev" & @CRLF & _
"LiteIntegration - Master" & @CRLF & _
"LiteLib - Dev" & @CRLF & _
"LiteLib - Master" & @CRLF & _
"Logviewer - Dev" & @CRLF & _
"Logviewer - Master" & @CRLF & _
"Messaging Services - Dev" & @CRLF & _
"Messaging Services - Master" & @CRLF & _
"OptionKeys - Dev" & @CRLF & _
"OptionKeys - Master" & @CRLF & _
"OptionKeysAPI - Dev" & @CRLF & _
"OptionKeysAPI - Master" & @CRLF & _
"Pools API - Dev" & @CRLF & _
"Pools API - Master" & @CRLF & _
"Pools Model - Dev" & @CRLF & _
"Pools Model - Master" & @CRLF & _
"Pools Model V2 - Dev" & @CRLF & _
"Pools Model V2 - Master" & @CRLF & _
"Pools Services - Dev" & @CRLF & _
"Pools Services - Master" & @CRLF & _
"Pools Services V2 - Dev" & @CRLF & _
"Pools Services V2 - Master" & @CRLF & _
"SubscriptionManager - Dev" & @CRLF & _
"SubscriptionManager - Master" & @CRLF & _
"SubscriptionManager2 - Dev" & @CRLF & _
"SubscriptionManager2 - Master" & @CRLF & _
"Tid Services - Dev" & @CRLF & _
"Tid Services - Master" & @CRLF & _
"TidHTTP - Dev" & @CRLF & _
"TidHTTP - Master" & @CRLF & _
"Upload templates to S3 - branch2Dev" & @CRLF & _
"Upload templates to S3 - Dev" & @CRLF & _
"Upload templates to S3 - Master" & @CRLF & _
"Upload templates to S3 - Test" & @CRLF & _
"VirtualWarehouse - Dev" & @CRLF & _
"VirtualWarehouse - Master" & @CRLF & _
"VirtualWarehouse Services - Dev" & @CRLF & _
"VirtualWarehouse Services - Master" & @CRLF & _
"VirtualWarehouse Services V2 - Dev" & @CRLF & _
"VirtualWarehouse Services V2 - Master" & @CRLF & _
"VW Axiom - Dev" & @CRLF & _
"VW Axiom - Master" & @CRLF & _
"VW Lite API - Dev" & @CRLF & _
"VW Lite API - Master" & @CRLF & _
"VW Remedy Events - Dev" & @CRLF & _
"VW Remedy Events - Master" & @CRLF & _
"VW Remedy Events Consumer - Dev" & @CRLF & _
"VW Remedy Events Consumer - Master" & @CRLF & _
"VW Remedy Events Lib - Dev" & @CRLF & _
"VW Remedy Events Lib - Master" & @CRLF & _
"VW Scheduled Tasks - Dev" & @CRLF & _
"VW Scheduled Tasks - Master" & @CRLF & _
"VW Sentinel - Dev" & @CRLF & _
"VW Sentinel - Master" & @CRLF & _
"VW Subscriptions - Dev" & @CRLF & _
"VW Subscriptions - Master" & @CRLF & _
"VW5 - Dev" & @CRLF & _
"VW5 - Master" & @CRLF & _
"WooCommerce API - Dev" & @CRLF & _
"WooCommerce API - Master" & @CRLF & _
"WooCommerce Model - Dev" & @CRLF & _
"WooCommerce Model - Master" & @CRLF & _
"WooCommerce Model V2 - Dev" & @CRLF & _
"WooCommerce Model V2 - Master" & @CRLF & _
"WooCommerce Services - Dev" & @CRLF & _
"WooCommerce Services - Master" & @CRLF & _
"WooCommerce Services V2 - Dev" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")