$re = '/(?:^fix(?:es)?(?:\s+(?:issues?|bugs?))?\s+(#?\d+(?:[\s,\+&and]+#?\d+)*))|(?:(?:issues?|bugs?)\s+(#?\d+(?:[\s,\+&and]+#?\d+)*))/i';
$str = 'Fix issues 18855 and 21188 - [spec/struct] Add \'Union Literals\' & \'Anonymous Structs & Unions\'
Fix Issue 21188 - Anonymous structs - not described.
Fix Issue 18855 - Behavior of Anonymous Union is Undocumented.
Fix: Non-overlapping union field data is not default initialized, it is
zeroed.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);