re = /(?i)(?=.{12})(?=.*[a-z])(?=.*\d)(?=.*[^a-z\d])/m
str = 'a2$45678901B
a2345678901B
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end