package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1-9]{1}[^SLOIBZsloibz|^0-9]{1}[^SLOIBZsloibz]{1}[0-9]{1}-?[^SLOIBZsloibz|^0-9]{1}[^SLOIBZsloibz]{1}[0-9]{1}-?[^SLOIBZsloibz|^0-9]{1}[^SLOIBZsloibz|^0-9]{1}[0-9]{1}[0-9]{1}`)
var str = `7TX1-EN6-JG01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}