import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\#[^\\S\\r\\n]*(\\S+).*\\s+^(?!\\#)[^\\S\\r\\n]*(\\S+)";
final String string = "# Arista \n"
+ "# aristaBgp4V2EstablishedNotification aristaBgp4V2PeerState\n"
+ "1.3.6.1.4.1.30065.4.1.0.1 0x06710000 1.3.6.1.4.1.30065.4.1.1.2.1.13(1,2)\\\n"
+ " # aristaBgp4V2PeerLocalPort\n"
+ " 1.3.6.1.4.1.30065.4.1.1.2.1.6(3,0)\\\n"
+ " # aristaBgp4V2PeerRemotePort\n"
+ " 1.3.6.1.4.1.30065.4.1.1.2.1.9(4,0)\n"
+ "# aristaBgp4V2BackwardTransitionNotificationaristaBgp4V2PeerState\n\n\n"
+ "1.3.6.1.4.1.30065.4.1.0.2 0x06710001 1.3.6.1.4.1.30065.4.1.1.2.1.13(1,2)\\\n"
+ " # aristaBgp4V2PeerLocalPort\n"
+ " 1.3.6.1.4.1.30065.4.1.1.2.1.6(3,0)\\\n"
+ " # aristaBgp4V2PeerRemotePort\n"
+ " 1.3.6.1.4.1.30065.4.1.1.2.1.9(4,0)\\\n"
+ " # aristaBgp4V2PeerLastErrorCodeReceived\n"
+ " 1.3.6.1.4.1.30065.4.1.1.3.1.1(5,0)\\\n"
+ " # aristaBgp4V2PeerLastErrorSubCodeReceived\n"
+ " 1.3.6.1.4.1.30065.4.1.1.3.1.2(6,0)\\\n"
+ " # aristaBgp4V2PeerLastErrorReceivedText\n"
+ " 1.3.6.1.4.1.30065.4.1.1.3.1.4(7,0)\n"
+ "#portTestResultNotification\n\n"
+ "1.3.6.1.4.1.4998.1.1.10.1.0.14 0x048a000d 1.3.6.1.4.1.4998.1.1.10.1.1.2(1,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.3(2,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.2.1(3,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.98(4,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.99(5,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.5.4.1.5(6,7)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.5.4.1.12(8,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.5.4.1.13(9,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.5.4.1.14(10,0)\n\n"
+ "# BigIp \n"
+ "#diskVolumeUsageNotification\n\n"
+ "1.3.6.1.4.1.4998.1.1.10.1.0.17 0x048a000e 1.3.6.1.4.1.4998.1.1.10.1.1.2(1,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.3(2,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.2.1(3,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.98(4,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.100(5,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.1.101(6,0)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.4.4.1.7(7,8)\\\n"
+ " 1.3.6.1.4.1.4998.1.1.10.1.4.4.1.5(9,0)\n\n"
+ "1.3.6.1.4.1.30065.3.8.1.0.1 0x06710004 1.3.6.1.4.1.30065.3.8.0.0.3.1.3(1,2)\\\n"
+ " # aristaRedundancyLastSwOverReason\n"
+ " 1.3.6.1.4.1.30065.3.8.0.0.4(3,0)\n\n"
+ "# wlsrStaImpersonation wlsrNodeMac\n"
+ "1.3.6.1.4.1.14823.2.3.1.1.100.6.1002 0x05f7000f 1.3.6.1.4.1.14823.2.3.1.1.100.100.5(1,0)\\\n"
+ " # wlsrLocation\n"
+ " 1.3.6.1.4.1.14823.2.3.1.1.1.1.1.20(2,3)\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}