re = /(?<=<td>)(.*)(?=<\/tr>)/
str = '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>HTML TABLE</title>
</head><body>
<table>
<colgroup><col/><col/><col/><col/><col/><col/></colgroup>
<tr><th>DisplayName</th><th>DisplayVersion</th><th>InstallDate</th></tr>
<tr><td>Adobe Acrobat Reader DC</td><td>18.009.20050</td><td>20171130</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Adobe Flash Player 28 ActiveX</td><td>28.0.0.137</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Adobe Flash Player 28 NPAPI</td><td>28.0.0.137</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Bonjour</td><td>3.1.0.1</td><td>20160316</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Cisco WebEx Meetings</td><td></td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Citrix Receiver</td><td>14.1.200.13</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Crystal Reports XI Release 2</td><td>11.5.8.82627</td><td>20131115</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>CutePDF Writer 3.0</td><td> 3.0</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Dropbox</td><td>41.4.80</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>EditPlus</td><td></td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Fiddler</td><td>2.4.9.4</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Google Chrome</td><td>63.0.3239.132</td><td>20131209</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Intel(R) Network Connections 18.7.28.0</td><td>18.7.28.0</td><td>20131114</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>iTunes</td><td>12.3.2.35</td><td>20160316</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Java 8 Update 151</td><td>8.0.1510.12</td><td>20171110</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>MGTEK Help Producer</td><td>3.1.2236</td><td>20131212</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft .NET Framework 4.7</td><td>4.7.02053</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft ASP.NET MVC 2</td><td>2.0.60926.0</td><td>20170711</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft LifeCam</td><td>3.60.253.0</td><td>20160415</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Office 2003 Web Components</td><td>12.0.6213.1000</td><td>20170913</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Office 365 Business - en-us</td><td>16.0.8730.2175</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Report Viewer Redistributable 2008 SP1</td><td></td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Silverlight</td><td>5.1.50907.0</td><td>20170614</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server 2008 R2 (64-bit)</td><td></td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server 2008 R2 Books Online</td><td>10.50.1600.1</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server 2008 R2 Native Client</td><td>10.52.4042.0</td><td>20150715</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server 2008 R2 Policies</td><td>10.50.1600.1</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server 2008 R2 Setup (English)</td><td>10.52.4042.0</td><td>20150715</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server 2008 Setup Support Files </td><td>10.1.2731.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server Browser</td><td>10.52.4000.0</td><td>20150715</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server Compact 3.5 SP2 ENU</td><td>3.5.8080.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server Compact 3.5 SP2 Query Tools ENU</td><td>3.5.8080.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server System CLR Types (x64)</td><td>10.52.4000.0</td><td>20150715</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft SQL Server VSS Writer</td><td>10.52.4000.0</td><td>20150715</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Sync Framework Runtime v1.0 (x64)</td><td>1.0.1215.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Sync Services for ADO.NET v2.0 (x64)</td><td>2.0.1215.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visio Professional 2010</td><td>14.0.7015.1000</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2005 Redistributable</td><td>8.0.61001</td><td>20140405</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2005 Redistributable</td><td>8.0.50727.42</td><td>20150430</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.17</td><td>9.0.30729</td><td>20140506</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.4148</td><td>9.0.30729.4148</td><td>20140917</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161</td><td>9.0.30729.6161</td><td>20140507</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729</td><td>9.0.30729</td><td>20160211</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4148</td><td>9.0.30729.4148</td><td>20140917</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161</td><td>9.0.30729.6161</td><td>20131213</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2010 x64 Redistributable - 10.0.40219</td><td>10.0.40219</td><td>20150212</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219</td><td>10.0.40219</td><td>20150212</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030</td><td>11.0.61030.0</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.61030</td><td>11.0.61030.0</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual Studio 2008 Shell (integrated mode) - ENU</td><td>9.0.30729</td><td>20140515</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual Studio 2010 Tools for Office Runtime (x64)</td><td>10.0.50903</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft Visual Studio Tools for Applications 2.0 - ENU</td><td>9.0.35191</td><td>20131206</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Microsoft WSE 2.0 SP3 Runtime</td><td>2.0.5050.0</td><td>20160415</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Mozilla Firefox 57.0.4 (x64 en-US)</td><td>57.0.4</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Mozilla Maintenance Service</td><td>57.0.4.6577</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>MSXML 4.0 SP2 (KB954430)</td><td>4.20.9870.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>MSXML 4.0 SP2 (KB973688)</td><td>4.20.9876.0</td><td>20131202</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>MSXML 4.0 SP2 Parser and SDK</td><td>4.20.9818.0</td><td>20160415</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>NVIDIA Graphics Driver 347.52</td><td>347.52</td><td>20150831</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>NVIDIA nView 146.33</td><td>146.33</td><td>20150831</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>NVIDIA WMI 2.20.0</td><td>2.20.0</td><td>20150831</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>OneLogin OTP</td><td>1.0.1</td><td>20160803</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Reservationless-Plus VoIP</td><td>5.15.11.061</td><td>20160122</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Safari</td><td>5.34.57.2</td><td>20131217</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>SAP Crystal Reports 2013 SP01</td><td>14.1.1.1036</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Snagit 10</td><td>10.0.0</td><td>20131206</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Symantec Endpoint Protection</td><td>14.0.2332.0100</td><td>20170329</td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>TeamViewer 11</td><td>11.0.59518</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>VLC media player</td><td>2.2.6</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>WinRAR archiver</td><td></td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>WinZip</td><td> 9.0 SR-1 (6224)</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Xerox Scan Assistant</td><td>1.04.32.00</td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
<tr><td>Xerox WorkCentre 3315</td><td></td><td></td><td>kratos.kcprod1.com</td><td>4104917a-93f2-46e5-941a-c4efd54504b7</td><td>True</td></tr>
</table>
</body></html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end