package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^&]( COMPANY| CO\.?)$`)
var str = `POWERWASH COMPANY
JONES & COMPANY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}