import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(?([\\d \\-\\)\\–\\+\\/\\(]+){6,}\\)?([ .\\-–\\/]?)([\\d]+))";
final String string = "(06442) 3933023\n"
+ "(02852) 5996-0\n"
+ "(042) 1818 87 9919\n"
+ "06442 / 3893023\n"
+ "06442 / 38 93 02 3\n"
+ "06442/3839023\n"
+ "042/ 88 17 890 0\n"
+ "+49 221 549144 – 79\n"
+ "+49 221 - 542194 79\n"
+ "+49 (221) - 542944 79\n"
+ "0 52 22 - 9 50 93 10\n"
+ "+49(0)121-79536 - 77\n"
+ "+49(0)2221-39938-113\n"
+ "+49 (0) 1739 906-44\n"
+ "+49 (173) 1799 806-44\n"
+ "0173173990644\n"
+ "0214154914479\n"
+ "02141 54 91 44 79\n"
+ "01517953677\n"
+ "+491517953677\n"
+ "015777953677\n"
+ "02162 - 54 91 44 79\n"
+ "(02162) 54 91 44 79\n"
+ "saddsadasdasd\n"
+ "asdasd\n"
+ "asdasd asdasd asd\n"
+ "asdasd\n"
+ "kjn asohas asdoiasd\n"
+ "23434 234 234 23\n"
+ "323\n"
+ "23434 234----234\n"
+ "///// ----\n"
+ "// id8834 3493934 //\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}