import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[[:upper:]]{2,}(?:[^[:alpha:]\\r\\n]|[[:alpha:]](?![[:lower:]]))*)+$";
final String string = "THE QUEEN’S HAND\n"
+ "THE QUEEN’s HAND\n"
+ "THE QUEEN’ss HAND\n"
+ "THE QUEEN’sAAs HAND";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}