$re = '/(?=((?:a(?=a*(\2?+b)))+\2))/m';
$str = 'aaabbb
abbb
aaab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);