import re
regex = re.compile(r"==========\nFind Your Why \(Simon Sinek;David Mead;Peter Docker\)\n- Your Highlight on Location (.*)")
test_str = ("==========\n"
"Find Your Why (Simon Sinek;David Mead;Peter Docker)\n"
"- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")