$re = '/(^[xX][= \0]{0,2})(\d{7}|\d{6})/';
$str = 'X=565565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);