package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TOTAL.*?(\d+)%`)
var str = `Name Stmts Miss Cover Missing
---------------------------------------------------------------
src/global_information.py 8 1 88% 6
src/settings.py 38 0 100%
src/storage_backends.py 4 4 0% 1-5
src/urls.py 8 0 100%
users/admin.py 1 0 100%
users/apps.py 3 3 0% 1-5
users/forms.py 5 0 100%
users/models.py 1 0 100%
users/tests/tests_views_urls.py 5 0 100%
users/urls.py 5 0 100%
users/views.py 1 1 0% 1
---------------------------------------------------------------
TOTAL 79 9 89%
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}