package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"key"\s*:\s*"([^"]*)"`)
var str = `blahblah "key":"value","TargetCRS": "Target","TargetCRScode": "vertical Code","zzz": "aaaa" sadzxc "sss"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}