import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\p{Ll}+|\\p{Lu}\\p{Ll}+|\\p{Lu}{2,}+)[,.!?]?(?:\\s|$)(*SKIP)(*FAIL)|(?:\\p{Ll}+|\\p{Lu}{2,}+|\\p{Lu}\\p{Ll}+)[,.!?]?";
final String string = "HelloEveryOne, СаломБаХама, Ҳама дарПеши ҷаҳонЯк мебошадАммо.\n"
+ "HELLOeveryOneHelloFORyouYOU HELLO everyOneHello FORyouYOU\n"
+ "can,BEcorrectedThisSTRINGinCorrectlyFORm\n"
+ "canBEcorrected ThisSTRINGin CorrectlyFORm.\n";
final String subst = "$0 ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}