# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s) *(<sample [^>]*>.*?<\/ ?sample>)"
test_str = ("<!DOCTYPE qhelp PUBLIC\n"
" \"-//Semmle//qhelp//EN\"\n"
" \"qhelp.dtd\">\n"
"<qhelp>\n\n\n"
"<overview>\n"
"<p>The C++ <code>throw</code> expression can take several forms. One form throws a new exception, whereas the\n"
"other re-throws the current exception. In the latter case, if there is no current exception, then the program\n"
"will be terminated. Presence of a re-throw outside of an exception handling context is often caused by the\n"
"programmer not knowing what kind of exception to throw.</p>\n\n"
"</overview>\n"
"<recommendation>\n"
"<p>The <code>throw</code> expression should be changed to throw a particular type of exception.</p>\n\n"
"</recommendation>\n"
"<example>\n"
"<sample language=\"cpp\">\n"
"void bad() {\n"
" /* ... */\n"
" if(error_condition)\n"
" throw;\n"
"}\n\n"
"void good() {\n"
" /* ... */\n"
" if(error_condition)\n"
" throw std::exception(\"Something went wrong.\");\n"
"}\n"
"</sample>\n\n"
"</example>\n"
"<references>\n\n"
" <li>Open Standards: <a href=\"http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2012/n3337.pdf\">Standard for Programming Language C++, draft n3337</a> [except.throw], clause 9, page 380.</li>\n\n\n"
"</references>\n"
"</qhelp>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.