$re = '/^(?!(?:[^\'\n]*\'){2})\p{L}+(?:[ \'-]\p{L}+){0,3}$/m';
$str = '// match:
one two three four
one-two-three-four
one-two-three four
vær så snill
тест регекс
re-read
under the hood
ONe
rabbit\'s lair
// not-match:
one two three four five
one two three four@
one-two-three-four five
rabbit"s lair
one\' two\'s
one1
1900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);