re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*[!@#$%^&*()_=+{}:<.>-])(?=.*[0-9])\S*$/m
str = 'Ab1%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end