$re = '/\b(([012])-(?!\2)([012])-(?!\2|\3)[012])\b/m';
$str = 'There are 2-1-0 reasons to buy 1-2-0 dogs, but only 1-2-1 to buy 0-2-1 cats.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);