const regex = /\(?\+|0{0,2}\(?49\)?[ ()]*[ \d]+[ ()]*[ -]*\d{2}[ -]*\d{2}[ -]*\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(?\\+|0{0,2}\\(?49\\)?[ ()]*[ \\d]+[ ()]*[ -]*\\d{2}[ -]*\\d{2}[ -]*\\d{2}', 'gm')
const str = `+491739341284
+49 1739341284
(+49) 1739341284
+49 17 39 34 12 84
+49 (1739) 34 12 84
+(49) (1739) 34 12 84
+49 (1739) 34-12-84
0049 (1739) 34-12-84
0049 (1739) 34-12-84
0049 (1739) 34-12-843
0049 (1739) 34-12-8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}