$re = '/^(?!system\.)[a-zA-Z0-9_][^$ \\\\0]*$/m';
$str = 'system.blah
systemmm.blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);