re = /(?<!(?:[%]{2})*[%])((?<format_string>[%][s])|(?<format_int>[%][di])|(?<format_float>[%][f])|(?<format_obj>[%][o])|(?<format_js_obj>[%][O])|(?<format_css>[%][c]))/m
str = '# Basic - Expandable object format string
Format string object: %o
# Basic - Single string format string
Format string string: %s
# Basic - Single integer format string
Format string integer: %i
# Basic - Single integer format string
Format string integer: %d
# Advanced - Message with expandable object, string, and integer format strings
Raw value: %o\\nTo string: %s\\nAs number: %i
# Advanced - Formatted message with styled heading, and body with value, escaped percentage
%c[Header]%c msg about %i values (%o)
%c[Header]%c msg about %i objects, %i%% total%c\\n Object array: %o
# Garbage
%z %i%p %q %3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end