$re = '/(?=^.{0,40}$)^[a-zA-Z-]+\s[a-zA-Z-]+$/';
$str = 'Chris Me';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);