import re
regex = re.compile(r"^(0?[0-9]?[0-9]|1[01][0-9]|12[0-7])$", flags=re.MULTILINE)
test_str = ("<--! select 0 or 000..127 sequences -->\n"
"0\n"
"00\n"
"000\n"
"001\n"
"002\n"
"004\n"
"010\n"
"011\n"
"021\n"
"100\n"
"101\n"
"110\n"
"115\n"
"120\n"
"125\n"
"127\n"
"135\n"
"139\n"
"141\n"
"201\n"
"222\n"
"230\n"
"245\n"
"247\n"
"250\n"
"254 sgnlfsf\n"
"2340\n"
"345\n"
"255\n"
"853\n"
"999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")