re = /^\s*(\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F]){1,8})|[1-9]\d+|\d))*\s*$/
str = '2 4 3 0xff0000 0xffff00 0x007700 0xff0077 0x0000ff 0xff7700 0x00ff77 0x888888'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end