$re = '@^/a/?($|\?)@m';
$str = '/a
/ab
/a?test
/a/
/a/?test
/abc?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);