using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*.*?\*\/(*SKIP)^|\/\/.*?$(*SKIP)^|'(?>\\?.)*?'(*SKIP)^|""(?>\\?.)*?""";
string input = @"$str = ""this is something"";
$str = ""this is {$another}"";
$str = ""could be {$hello['world']}"";
$str = ""and $hello[world] another"";
$str = ""building <div style=\""width: 100%\"" data-var=\""{$var}\""></div>"";
$str = '<elem prop=""' . $var . '"">';
$str = '<div class=""my-class ' . $my_var_class . ' my-other-class"">';
$str = ""'single quotes in double quotes'"";
$str = '""double quotes in single quotes""';
$xml .= "" <$schemaPrefix:import location=\"" . $ii['location'] . '"" namespace=""' . $ns . ""\"" />\n"";
// this is it's own comment with an apostrophe
$str = ""'single quote'""; $str = '""double quote""';
/* comment's apostrophe */ $str = ""'single quote'""; $str = '""double quote""';
/* comment's apostrophe */ $str = '""double quote""'; $str = ""'single quote'"";
$str = '""double quote\'d apostrophe""';
$str = ""double quote'd apostrophe""; $str = ""'single quote'""; $str = '""double quote""';
$str = ""double quote'd apostrophe""; $str = '""double quote""'; $str = ""'single quote'"";
// this is it""s own comment with a double quote
$str = ""'single quote'""; $str = '""double quote""';
/* comment""s 2 quote */ $str = ""'single quote'""; $str = '""double quote""';
/* comment""s 2 quote */ $str = '""double quote""'; $str = ""'single quote'"";
$str = '""double quote\'d apostrophe""';
$str = ""double quote'd apostrophe""; $str = ""'single quote'""; $str = '""double quote""';
$str = ""double quote'd apostrophe""; $str = '""double quote""'; $str = ""'single quote'"";";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}