# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=SUBH2002078568)[\s\S]+?(?=SUBF2002078568)"
test_str = ("HMT940040324\n"
"SUBH2002078568\n"
"2002078568{1:F01BANK MBI}{2:I940MAP}{4:\n"
"2002078568:20:20210420182417\n"
"2002078568:25:2002078568\n"
"2002078568:28C:00075\n"
"2002078568:60F:D210420IDR0,\n"
"2002078568:62F:D210420IDR0,\n"
"2002078568-}\n"
"SUBF2002078568\n"
"SUBH2003001298\n"
"2003001298{1:F01BANK MBI}{2:I940MAP}{4:\n"
"2003001298:20:20210420182417\n"
"2003001298:25:2003001298\n"
"2003001298:28C:00075\n"
"2003001298:60F:C210420IDR111520964,38\n"
"2003001298:62F:C210420IDR111520964,38\n"
"2003001298-}\n"
"SUBF2003001298\n"
"SUBH2002078568 // *Added this account from the top*\n"
"2002078568{1:F01BANK MBI}{2:I940MAP}{4:\n"
"2002078568:20:20210420182417\n"
"2002078568:25:2002078568\n"
"2002078568:28C:00075\n"
"2002078568:60F:D210420IDR0,\n"
"2002078568:62F:D210420IDR0,\n"
"2002078568-}\n"
"SUBF2002078568- // End\n"
"FMT9400000004")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.