package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w']+`)
var str = `How's it going $#$#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}