$re = '/^(.*?)(\d+)?(?<=.)\.exe$/m';
$str = 'abc.exe
.exe
abc%.exe
123.exe
abc 123.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);