import re
regex = re.compile(r"(?:import|from) ['\"](.+?)['\"];", flags=re.MULTILINE)
test_str = ("import {\n"
" Component\n"
"} from '@angular2/core';\n"
"import defaultMember from \"module-name\";\n"
"import * as name from \"module-name \";\n"
"import { member } from \" module-name\";\n"
"import { member as alias } from \"module-name\";\n"
"import { member1 , \n"
"member2 } from \"module-name\";\n"
"import { member1 , member2 as alias2 , member3 as alias3 } from \"module-name\";\n"
"import defaultMember, { member, member } from \"module-name\";\n"
"import defaultMember, * as name from \"module-name\";\n"
"import \"module-name\";\n"
"import * from './smdn';\n\n"
"/**\n"
" *Add all needed dependency to this module\n"
" *app requires those import modules to function\n"
"**/\n\n"
"let modules = [];")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")