$re = '/(?=[^|])(?:[^|]*\([^)]+\))*[^|]*/m';
$str = 'make|aaa|select.aaa|ttt||actived_by(creator.url|test|ali)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);