import re
regex = re.compile(r"[a-zA-Z0-9\-\_]*\.[a-zA-Z0-9\-\_]*\.\w{1,3}(\.\w{1,3})?", flags=re.MULTILINE)
test_str = ("\n\n"
"service.mensfitness.co.uk\n"
"updates.mensfitness.co.uk\n"
"promo.mensfitness.co.uk\n"
"deals.mensfitness.co.uk\n"
"subs.mensfitness.co.uk\n\n"
"service.healthandfitnessoneline.co.uk\n"
"updates.healthandfitnessoneline.co.uk\n"
"promo.healthandfitnessoneline.co.uk\n"
"deals.healthandfitnessoneline.co.uk\n"
"subs.healthandfitnessoneline.co.uk\n\n"
"service.custompc.co.uk\n"
"updates.custompc.co.uk\n"
"promo.custompc.co.uk\n"
"deals.custompc.co.uk\n"
"subs.custompc.co.uk\n\n"
"service.digitalslrphoto.com\n"
"updates.digitalslrphoto.com\n"
"promo.digitalslrphoto.com\n"
"deals.digitalslrphoto.com\n"
"subs.digitalslrphoto.com\n")
subst = "'\\g<0>'"
result = regex.sub(subst, test_str)
if result:
print(result)