re = /^(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)$/m
str = '1.1.1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end