$re = '/\/\/(www\.)?([\w\.]+)\/?/m';
$str = 'https://www.southwest.com/about/so
//google.com/home
https://newsite.org
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);