package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?'d'(?:3[0-9]\s+)){2})2f\s+(\g'd'{2})2f\s+(\g'd'{4})`)
var str = `XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX
32 37 2f 30 36 2f 32 30 31 37 XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX
XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX
XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX 32 37 2f 30
36 2f 32 30 31 37 XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX
XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}