package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^n.*a.*u.*j.*a.*s.*o.*n.*$`)
var str = `Nextcloudserver Admin User Jason
Nextcloudserver Admin User Peter
smith
john.smith@gmail.com
Super Secret Server
j.smith@john-international.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}