#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?=(?:BAD))(?=(?:.{26}(...)))"
Local $sString = "ABCDBCADBADCBABDDACAABCDB" & @CRLF & _
"1#JHHHF##@@GGIHHHIII==DDS" & @CRLF & _
"ACBDAACBABDCCBBDCDBBADADA" & @CRLF & _
"ISHFIDH#H@1JD=@HHII##GG=H" & @CRLF & _
"CCCDDAABCCBABBADBADBAAABA" & @CRLF & _
"%%$$#@GGTTT&%MHTHWAIIHJWI"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")