$re = '/\$([\w -]+)(?!\w|,?\s*=)(,?)/';
$str = '$a, $a, $a
$a, $a = \'\', $a
$a
$a,
$a = \'\'
$a = \'\',
$a = \'\', $a
$a, $b, $c, $hi = "", $na';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);