$re = '/^[a-zA-Z\sа-яА-Я -]*$/';
$str = 'Красен-Димитров Петров';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);