$re = '/^\s*\[(\w+)\]/m';
$str = '[Compiler]
Path=C:\\ProgramFiles (x86)\\ProtonIDE\\PDS
Database=C:\\Program Files (x86)\\ProtonIDE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);