package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\s]phone[^\w\s]`)
var str = `phone phoneno .phone.phone`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}