const regex = /-\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d{2}$', 'gm')
const str = `2018-09-04`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);