re = /^.*(youtu.be\/|list=)([^#\&\?]*).*/
str = 'https://www.youtube.com/watch?v=4jduuQh-Uho&list=PLBOh8f9FoHHjOz0vGrD20WcTtJar-LOrw&index=3
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end