$re = '/^(?!.* (\d+) \1 \1 \1)/m';
$str = '21 21 21 21 21
21 21 21
21 21 21 22 21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);