$re = '/(?:^|\B)#[a-zA-Z][a-zA-Z0-9_]{1,19}\b/';
$str = '#aaaaa
#11111
#1aaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);